Motorhome Facts Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
302 Posts
Discussion Starter · #1 ·
hi everyone yesterday the relay under my passenger seat started to chatter ducato 03, nordel electronica zig unit , it was only intermittent ,today ive tryed to get it to chatter again by putting a load on it ,but to no avail .
I know the likes of daveb and clive mott are quiet up on these matters,id rather get the problem sorted now , before theres a problem ...............not been good for me and electrics lately , your advice would be greatly welcome , thanks in advance gary
 

·
Registered
Joined
·
253 Posts
ozwhit said:
I know the likes of daveb and clive mott are quiet up on these matters,.... gary
Those two, quiet on these matters? -nah! :p

Could it be that the voltage on the switching circuit was low, and not causing enough current to hold the relay 'on', so it bounces on/off ?

Just an idea; I'm sure DaveB or Clive will put us straight....

:lol:
 

·
Registered
Joined
·
3,073 Posts
A little more detail would help.
Which relay? How many miles has the van done? Is it either of the split charge or fridge relays perhaps?.
What happen if you rev the engine? Does the chatter rate change? Does the ignition warning light behave normally or does it have a dim or flickering glow? If so it could be the alternator on the way out.
OR Perhaps a bad chassis connection under the seat?.

C.
 

·
Premium Member
Joined
·
13,788 Posts
Well I can vouch that if you now ask Hampshireman about chattering relays he'd probably say measure the terminal voltage of your battery and take things from there :)

(Nothing like learning the hard way!)

Dave
 

·
Registered
Joined
·
302 Posts
Discussion Starter · #5 ·
heres some more info , van has 35k on clock , alternator has been stripped and checked ( earlier charging problem, due to earth strap) the relay is next to the zig unit under the seat ,
revving the engine doesnt seem to effect the chatter
chatter appears to show up early when i first get going .
and then sporadically , hope this helps gary
 

·
Registered
Joined
·
3,073 Posts
In that case I suspect the alternator even more as you have had reason to doubt it previously.

But we still don,t know what relay it is, only where its situated?

Can you unplug this relay and tell us what stops working?

C.
 

·
Registered
Joined
·
3,073 Posts
Yes,
It looks like a 12 volt relay. I expect there are several of them in the van with the same part number.

Surely, if you leave it unplugged you will eventually find that which is not working?

Does the fridge work on 12 volts when driving?
Does the leisure battery get charged while driving?

Or is it nothing to do with the habitation equipment and something to do with the original vehicle? Checked the stop lights lately?

And so on.
C.
 

·
Registered
Joined
·
302 Posts
Discussion Starter · #11 ·
hi all , ive managed to do some investigation tonight , whilst checking my rear lights ,it appears that the one side of my of rear lights do not work , but the brake lights come on when you switch the lights on , and when the lights are of ,if you press the brake pedal ...............the dash will light up .
Looking underneath at the rear the earth connections look badly rusted and some of the block connectors look rusty as well , is it possibe that the relay maybe chattering due to bad earthing . fridge is working by the way and leisure batterys charging as well , any ideas thanks gary
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top