Motorhome Facts Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
....having a problem with the step of my Euroyacht 180X, since the cold weather. The motor spins when the button is pressed (or the engine is started) but nothing seems to happen. It sounds like the shaft is spinning but something needs tightening. Can anyone help, please..?? Thanks..!
Tony
 

·
Registered
Joined
·
28 Posts
See if it has disengage as it has a manual setting has a lever on side of motor that you push or pull. Also check electrical connections and fuse connection.
mine did same I had just a whirring noise eveuntually didnt even get the noise changed fuse and is now great.
 

·
Registered
Joined
·
28 Posts
HI
Congratulations we are really pleased with ours.
Re manuals we have an iveco chassis and engine the manual for that is ok.
The mobilvetta manual we have is not very useful as it has very little detail in it you will be best to just explore your home and work it out if you have any Specific Questions please dont hesitate to ask and if I can answer I will.

Regards

Zeb..
 

·
Registered
Joined
·
5 Posts
transittony said:
....having a problem with the step of my Euroyacht 180X, since the cold weather. The motor spins when the button is pressed (or the engine is started) but nothing seems to happen. It sounds like the shaft is spinning but something needs tightening. Can anyone help, please..?? Thanks..!
Tony
I had a 190LX? with a similar problem which turned out to be a broken roll pin on the motor shaft.
 

·
Registered
Joined
·
39 Posts
Zebuk, Thanks for you reply it is appreciated. If possible I would like to have a copy of the Iveco manuals. I will explore the MH and come back to you if I have any specific questions.

Not too sure how we can get the copy of the manuals over to me

Once a again thank you very much


HMFIC
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top