Motorhome Facts Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, we’ve recently purchased a Rapido i1090, and the underfloor heating and blowers do not appear to be working in the bedroom, even when we have turned the independent thermostat ( in the bedroom ) up to the max… can anyone advise please….?
 

·
Premium Member
2017 Hymer Exsis-i 504
Joined
·
12,721 Posts
Hi Jo, welcome to the forum.

I wonder has a corrugated pipe come loose at a joint? As Drew asked - is it heating the rest of the MH?
 

·
Premium Member
Joined
·
10,391 Posts
2 great answers: If what Drew alludes to is correct and you have heating elsewhere, then what Jean suggests is probably also correct.

Does the boiler make a noise when on full chat? If not then maybe it's not working so you would need to have the fault diagnosed. could be as simple as a blown fuse.

Aside from that, welcome!
 

·
Premium Member
Joined
·
4,447 Posts
Normally blown air heating will not blow through all the outlets if they are all fully open. Try restricting the two or three that get the most throughput...ie adjust the flap on them!
 

·
Premium Member
Joined
·
10,391 Posts
Of course none of us have mentioned the flaps yet Ted, nice one: OP - are the flaps set to open at the air outlets?
 

·
Premium Member
2017 Hymer Exsis-i 504
Joined
·
12,721 Posts
Jo was online when I posted my answer so should at least have seen the 1st couple. Maybe it's harder to navigate the site than we think.
 

·
Premium Member
Joined
·
10,391 Posts
Could be another one hit wonder Jean.

We seem to get more on this site than other forums I am a member of.
 
  • Like
Reactions: JanHank
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top