Motorhome Facts Forum banner

Odd problem with Dometic fridge gas operation

710 Views 10 Replies 5 Participants Last post by  BogWelsh
Hi, I've got a problem with the Dometic RMS8551 fridge (not AES) in my AutoTrail motorhome. Any and all suggestions would be appreciated.

Day 1: Walking past the van and the gas igniter was sparking athough the fridge was turned off at its front control panel. Got the keys and returned to the van and sparking had stopped. Turned the fridge on at the control panel but couldn't get it to operate on gas - not sparking or igniting when pressing the button for gas operation. Checked: i) fridge is operating (getting cold) on mains power and switching ok between mains and 12V when the engine is running ii) there is gas in the bottle iii) no errors to reset iv) no build-up of dirt in the igniter.

Day 2: Next day and magically everything was functioning OK - able to switch between mains and 12V and the gas was operating as normal, and lighting on the first click.

Day 3: Now back to where we were on Day 1 - operating fine on mains and 12V power but not operating on gas - no spark and no ignition. One difference this time was that after selecting gas the fridge showed an error after a few seconds. Cleared the error but it returned every time I tried to switch to gas.

Any suggestions about the source of the problem? The control panel appears to be functioning OK. The big mystery (and hopefully the biggest clue) is why would the gas igniter start clicking on its own?

1 - 5 of 11 Posts
Thank you all for the replies.

It's using propane for the same reasons as mentioned.

The error appears to be the standard one that comes up when the fridge tries to ignite but fails because there is no gas supply e.g. empty bottle / tap turned off.
Thanks Jijawa. Yes it's almost certainly an electrical fault -the problem is pinpointing exactly what's gong on. I'm going to splash out on a new control panel and go from there.
Thanks a gain. I've tried disconnecting and reconnecting the control panel but it made no difference.
After repeated button pressing the fridge eventually switched over to gas but then it wouldn't switch back to electric or turn off and I had to disconnect the ribbon cable at the back of the panel.

Based on that I decided it had to be a control panel fault -- how else would the gas igniter start sparking on its own and why else would the fridge refuse to turn off? Anyway, a new panel arrived over the weekend, has been connected and so far it looks good (...though I'm not completely confident about declaring job done - time will tell!)

Thanks again to all for your suggestions.
  • Like
  • Helpful
Reactions: 3
1 - 5 of 11 Posts