Motorhome Facts Forum banner
1 - 20 of 20 Posts

·
Premium Member
Joined
·
211 Posts
Discussion Starter · #1 ·
Out of my 3 gas burners i can only light the the smallest one. The medium and large rings take a spark, burn until i ley go of the knob, both go out everytime!! Do i have to clean them or is there something more sinister at play?? Any help will be much appreciated
Thanks
 

·
Premium Member
Joined
·
11,380 Posts

·
Premium Member
Joined
·
23,211 Posts
Silly question, but I will ask anyway;

You are, of course, holding the knob in for a number of seconds after it lights aren't you ?

I know it takes a few seconds for the thermocouple to warm up, I have to say I have never looked for it, but surely, it has to be where the heat will get to it ? So OUGHT to be visible, but I don't know where it is for each burner.

My thoughts are that "energetic" cleaning may have moved them a touch, not a lot, but enough to move it out of line.

Like Terry, I would NOT advocate playing around in a DIY manner with gas, the potential consequences are horrendous and I am very much safety orientated (belt, braces AND a piece of thick rope to hold up trousers - just in case).

I believe that even "normal" gas fitters are not permitted to work on MH supplies, the GasSafe register requires an extra LPG module, I think.

But, lifting the burner as for cleaning, may show where the problem lies by comparing all three., can't do any harm (says he with fingers, arms, legs, toes AND eyes crossed).

Warning; no responsibility accepted for any ensuing carnage if my advice is, like a lot of what I post, a total load of manure from male cattle. 💩
 

·
Premium Member
2017 Hymer Exsis-i 504
Joined
·
12,985 Posts
Try lifting the kettle/pan up, away from the flames before you let go of the knob. I used to have to do that with my previous MH. I don't know if it just needed a bit more air or what but it worked!
 

·
Premium Member
Joined
·
28,598 Posts
I always remember hearing a distinct 'click' 20 seconds after turning the gas off after boiling a kettle when the thermocouple or bi metal strip opened to stop the gas.

Ray.
 
  • Like
Reactions: Ingo Sundowner

·
Premium Member
Joined
·
1,203 Posts
Out of my 3 gas burners i can only light the the smallest one. The medium and large rings take a spark, burn until i ley go of the knob, both go out everytime!! Do i have to clean them or is there something more sinister at play?? Any help will be much appreciated
Thanks
Firstly check that the flame fan cap is not clogged. Then there are two little pips around the burner. One is the spark which will be pretty obvious, the other is the thermocouple (TC). Hold a lighter on the TC tip when you release the gas control knob. If the gas stays alight then the TC is working ok, as has been stated may have been moved when cleaning. You can gently move the TC towards the flame. If the gas does not stay lit then it is possible that the spade connectors to the TC are corroded, simple job to pull off, clean the spades with wire wool & replace. These are prone to corrosion, they are also in the most awkward place imaginable. It is possible to test the TC by connecting a meter across the TC terminals & holding a lighter against the tip of the TC, a small voltage should be seen. If all this fails then you are probably looking at a new TC but beware they are stupidly expensive.
 

·
Premium Member
Joined
·
11,380 Posts
Ahh, something a complete idiot in terms of lpg has a job for tomorrow, always great for a grumpy, cantankerous old git like myself!!!
Many thanks to all of you
Perhaps one of these will help explain it to others.
Got myself one from Amazon recently. :grin2:

 

·
Premium Member
Joined
·
11,380 Posts
It wasn't someone else got it for you Terry?!?
:grin2::grin2: No Jean, it raised some hilarious laughter when I unveiled it on my new slimline body. :grin2:
(Well maybe not slimline but 3 stone lighter since my stroke.)

Terry
 

·
Premium Member
Joined
·
8,444 Posts
Out of my 3 gas burners i can only light the the smallest one. The medium and large rings take a spark, burn until i ley go of the knob, both go out everytime!! Do i have to clean them or is there something more sinister at play?? Any help will be much appreciated
Thanks
Trace the 2 thermocouples back to the Spade connectors. Pull the connector off and back on a couple of times. The Rings should work fine.
 

·
Premium Member
Joined
·
211 Posts
Discussion Starter · #15 ·
Right guys, problem sorted!! Checked the pin by the working burner, adjusted the other two accordingly with a clever device called index finger and bingo, I'm back in business!!
Thank you not only for your help, but also for making me feel like a technical achiever 😁😁
 

·
Premium Member
Joined
·
1,203 Posts
Right guys, problem sorted!! Checked the pin by the working burner, adjusted the other two accordingly with a clever device called index finger and bingo, I'm back in business!!
Thank you not only for your help, but also for making me feel like a technical achiever 😁😁
Well done and no doubt saved yourself a big repair bill in the process.
 

·
Premium Member
Joined
·
23,211 Posts
Lessons learned;

1. Asking on here is foc

2. There is some good advice on here if the correct question is posed, if you ignore Penquin.

3. Cleaning the hob is a dangerous occupation and should only be very rarely tackled.

4. If some else can be persuaded to clean it, then it's their fault.

5. When in doubt, refer to the last clause of 2.
 

·
Premium Member
Joined
·
11,380 Posts
Lessons learned;

1. Asking on here is foc

2. There is some good advice on here if the correct question is posed, if you ignore Penquin.

3. Cleaning the hob is a dangerous occupation and should only be very rarely tackled.

4. If some else can be persuaded to clean it, then it's their fault.

5. When in doubt, refer to the last clause of 2.
In terms of fault our house works on the premise, the last person to touch it broke it. 😆

Terry
 
  • Like
Reactions: Penquin

·
Premium Member
Joined
·
28,598 Posts
Narrrr, I always get "It was alright when I used it last".

Ray.
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top