Motorhome Facts Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
634 Posts
Discussion Starter · #1 ·
Our Truma fire has been working fine for years now and without warning when on 2000w it stopped , tried it again after letting it cool down and tried 1 kw then 500 w and it still would not work. The fans do work and the 13 amp fuse is ok plus the mcb. Having looked down the back of the fire where the controls for the settings end up in a plastick box i did not see any trip swithes etc. Left it for 24 hrs and tried again and it came on but only lasted for 10 minuets then cold again. Can any one tell me the next step?, many thanks if you can.
 

·
Registered
Joined
·
271 Posts
Mine's been like that from new! Problem is that when I took for the dealer to look at it worked. It, of course, didn't work when we next came to use it.
Hopefully getting it sorted now.
Has been suggested that it may be the thermostat but I don't know what the problem is ...............but somebody on here may be able to offer help.
Brian
 

·
Registered
Joined
·
143 Posts
Truma Fire not working on A/C

We had a similar problem with the Truma heater in a caravan a while back. The mains connection was a 3 pin plug at the back of the heater. This had simply worked out with vibration over time.
Only the heater elements used the A/C supply, fans and control systems are all 12v so work when A/C is off.
Unfortunately the heater may have to be removed to get the plug back in.

Colin
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top